Tuesday, April 4, 2017

Tutorial MultiHC dan PAC proxy hc-reges007

Sebelumnya mohon maaf untuk postingan multi hc terdahulu saya tarik karena sudah tidak berlaku lagi
Saya sudah mempersiapkan tutorial dengan metode baru yang lebih ringkas,
sebelum memulai saya harap bagi yang baru gabung di blog ini harap membaca tutorial dasar 1 dan 2 disini:
  1. Tutorial basic penggunaan hc-reges007 
  2. Tutorial HandyCache transparent MikroTik  
Untuk dapat menggunakan fitur MultiHC dan PAC proxy HC-REGES007 minimal harus pada versi 2.0.17 build : 30032017
(build berdasarkan tanggal/bulan/tahun)
cara mengetahui build number klik option handycache pilih menu Extensions dan klik 2x pada rule "Aktivasi"
disini juga terdapat ID-komputer Anda sebagai unik id cpu Anda.





















Khusus user yang sudah register otomatis sudah mendapatkan fitur terbaru karena sudah otomatis update, untuk free user bisa dwonload ulang build terbaru disini (pilih tanggal yang terbaru) :
HC-REGES007

Saya akan jelaskan dulu maksud pengertian dari MultiHC
MultiHC adalah upaya untuk menjalankan progran HandyCache lebih dari satu (port) dalam satu komputer
tujuannya adalah untuk menambah daya tampung request dari klien, sebab default HandyCache hanya dapat menampung sekitar 400 active connection per detik, jika hanya untuk jumlah 10 PC klien saja cukup hanya menjalankan satu port HandyCache, namun jika lebih dari 10 PC klien harus menggunakan lebih dari satu port HandyCache (tidak mutlak namun menyesuaikan kondisi jaringan saja).


Silahkan buka menu Extensions dan klik 2x rule "MultiHC dan PAC proxy" dan nanti akan muncul menunya yang berisi pilihan untuk portnya
berikut tampilannya:































Penjelasaan:
kotak port untuk HC1 adalah diisi port HC primarynya, karena default HC-REGES007 memakai port 3128 maka ya harus diisi portnya 3128 seperti pada gambar, jika tidak ingin memakai port 3128 maka rubah dahulu port HC primarynya di menu "Access" dan MultiHC jangan diset enable alias jangan dicentang dahulu "enable HC1" dan seterusnya.


Misal jika memakai port 8080 maka rubah dahulu di menu "Access" seperti berikut:


















Setelah itu baru port MultiHC diisi sesuai kebutuhan yang penting port primary untuk HC1 sedangkan untuk port HC2 dan seterusnya bebas.
HandyCache akan otomatis aktif sesuai yang dipilih (Enable HC1-HC8), dalam contoh ini saya akan mengaktifkan 2 port HandyCache saja.
 


Saya pilih HC1 dengan port 3128 dan HC2 dengan port 3129 setelah itu klik "SAVE" nanti akan otomatis loading HC kedua.
































Dan berikut tampilan dengan dua program HandyCache dengan port 3128 dan port 3129, setelah itu Anda bisa memakai kedua port tersebut.
































OK setelah sukses membuat MultiHC berjalan sekarang lanjut membahas fitur PAC proxy dari HC-REGES007 yaitu script proxy auto fail over dan load balance. Asumsi disini Saya anggap Anda sudah sukses menerapkan tutorial basic 1 dan 2 jika belum harap Anda pelajari dahulu pengertiannya supaya mudah memahami langkah berikutnya.

Untuk memasang PAC Proxy cukup mudah yaitu dng url http://ip_handycache:port_hc/reges.pac, saya ambil contoh ip HandyCache adalah 192.168.3.2 dan port 3128 sesuai contoh MultiHC diatas.
Jadi formatnya seperti ini "http://192.168.3.2:3128/reges.pac"

Silahkan ke Internet Option untuk mengganti settingan ip proxynya untuk dirubah ke auto script seperti berikut:




























Jika sebelumnya memakai settingan proxy server manual maka hilangkan centangnya ya, settingan pada internet option adalah sama dengan settingan yang ada di google chrome. Dan untuk browser Firefox cukup memakai defaultnya saja atau pastikan seperti ini settingan ip proxynya:
































Sampai disini sudah selesai untuk menjalankan MultiHC dan menggunakan PAC proxy, Silahkan diterapkan pelan-pelan saja jika ada yang terlewatkan atau tidak sesuai dengan topologi di jaringan Anda maka akan terjadi error.


Kelebihan memakai PAC Proxy adalah : 
  • trafik dari klien dibagi menjadi dua yaitu ke port 3128 dan 3129 jadi beban HC lebih ringan
  • jika terjadi error pada proxynya, PAC proxy akan otomatis fail over ke DIRECT yaitu membypass tanpa lewat  proxy jadi langsung seperti tanpa proxy, maka tidak menggangu user yang sedang browsing
  • dengan PAC proxy, SERVER bisa sejajar dengan KLIEN jadi otomatis trafik HIT-nya full speed karena tanpa lewat router mikrotik, jadi cocok buat warnet non-mikrotik.

Kekurangan memakai PAC Proxy adalah : 
  • jika terjadi fail over akibat proxy error atau server mati maka jika proxy sudah on dan normal browser akan tetap membypass proxy (DIRECT) selama browser tidak terjadi closed.
  • tapi jika browser terjadi reload (reopen) maka PAC Proxy sudah bisa berjalan normal kembali.


Dan satu lagi Extensions MultiHC dan PAC Proxy ini GRATIS jadi bisa dipasang pada HandyCache settingan siapa pun.

Jadi cukup diambil extension  "Multi_hc.lua" saja

 























Cukup sekian dulu tutorial dan penjelasan singkat dari saya
Terima kasih atas kunjungannya.

best regards












Monday, January 30, 2017

Free web-filter porn dan judi

yang pakai webfilter silahkan update extensionnya dng yg terbaru ini
timpah saja extension lalu reload

Free web-filter untuk handycace
auto update untuk rule filternya
sedot :
Extension Web-filter



Thursday, January 12, 2017

Free VPN DNS untuk bypass dns atau transparent dns

Berikut contoh untuk menggunakan VPN sebagai gateway dns atau untuk membypass dns dari ISP ke dns luar



Cukup copy paste saja ke terminal winbox

/interface pptp-client
add add-default-route=no allow=pap,chap,mschap1,mschap2 connect-to=\
    uk.websitevpn.com dial-on-demand=no disabled=no keepalive-timeout=60 \
    max-mru=1450 max-mtu=1450 mrru=1600 name=query-dns password=freevpn \
    profile=default-encryption user=websitevpn.com

/ip firewall nat
add action=masquerade chain=srcnat out-interface=query-dns
add action=dst-nat chain=dstnat dst-port=53 protocol=udp to-addresses=8.8.8.8 \
    to-ports=53

/ip route
add distance=1 gateway=query-dns routing-mark=ke_vpn_dns

/ip route rule
add dst-address=8.8.8.8/32 table=ke_vpn_dns
 

Tulisan ini sekedar contoh dan hanya menggunakan layanan FREE VPN sebagai query dns, jika Anda menginginkan yang lebih stabil silahkan memakai VPN berbayar.

Tuesday, November 15, 2016

Tutorial HandyCache transparent MikroTik

Ada dua metode untuk menggabungan HandyCache dengan MikroTik yaitu sejajar dengan klien dan sejajar dengan MikroTik

sejajar dengan klien
Pertama saya akan membahas metode sejajar dengan klien, gambar topologinya sebagai berikut
sebelum melangkah lebih lanjut silahkan simak dahulu tutorial dasar penggunaan handycache disini :
Tutorial dasar HC-REGES007
setelah tahap dasar tersebut sukses baru melangkah ke berikut :

Sejajar dengan klien



Saturday, November 12, 2016

Tutorial basic penggunaan hc-reges007

Bagi Anda yang masih pemula menggunakan HandyCache khususnya yang ingin menggunakan hc-reges007
silahkan simak baik-baik tutorial penggunaan serta tips untuk troubleshoot.
Jika belum punya hc-reges007 silahkan unduh pada link dibawah ini :
HC-REGES007

Ekstrak dan taruh folder HandyCache pada root C:\ seperti pada gambar ini :
(karena saya buildnya make di C:\ jd buat jaga-jaga klo ada yg error saja)




















Yang pertama harus diperhatikan adalah settingan port dan folder cachenya, jadi silahkan cermati dan hafalin portnya kalau default dari saya memakai port 3128 dan folder cache berada di drive D:\Cache sama juga untuk folder cache video youtube, untuk youtube silahkan disesuaikan dengan mengklik 2x extension YouTube GUI

Thursday, October 27, 2016

Selamat datang di rumah baru (welcome to the new blog)

Disini nantinya akan menjadi rumah baru dari blog lama (reges007.wordpres.com) yang akan up-to-date membahas dan juga update layanan berbayar dari HC-REGES007